July 31, 2010

InstallShield 2010 LE Bug Hell

I decided to play with InstallShield 2010 LE today and for the life of me I can't even get it to build a simple MSI. Every time I try to build I get the error:

-5002: Product Configuration 'Express' is not found in the specified project. Verify that the Product Configuration name is correct.

This error message is useless because IS 2010 LE doesn't allow you to edit such things as product configurations. Regardless I checked and it all seems to be there in both the GUI and ISProductConfiguration table. It just refuses to find it.

Then it became interesting. I double clicked on the error and was taken to the InstallShield KB search page. I selected Product and Version and low and behold Limited Edition wasn't even a choice so I left it blank.

This is when I came upon Q109699: ERRDOC: Build Error 5002. I clicked on it and received the following error message:



The funny part is the name of the script: SuckerFish. Yes, I know this is a common web script but at this moment if feels like the universe is trying to tell me something:

Developers are nothing but fish to InstallShield and that they are suckers for trying IS 2010 LE.

3 comments:

Anonymous said...

works like a charm here...maybe its your machine...can you create an isle project by itself and build it?

Christopher Painter said...

I'm on vacation right now but when I get back I'll give it yet another try on another machine.

Anonymous said...

I have exactly the same problem. Tried it firstly on our whole project, but get the following error:

"Error 1 -5002: Product Configuration 'Express' is not found in the specified project. Verify that the Product Configuration name is correct.

Then I tried to do a new C# project with one form, but when adding an Installshield LE project and then building it, it comes out with the same error.

Any ideas?

Thanks in advance.